ARTICLE DETAIL

建站实战干货

来自一线的建站与推广经验沉淀,每一条都经过真实交付验证。

加载arcgis切片服务网络请求有大量404错误

2026/9/23 0:37:04 拓冰建站 浏览量
加载arcgis切片服务网络请求有大量404错误

需求:

前端访问arcgis切片服务时,在网络请求中出现大量404(Not Found)错误,切片时设置了感兴趣区域,在感兴趣范围内请求切片时能够正常返回切片。

问题分析:

设置感兴趣区域切片的目的是减少站点切片缓存占用磁盘空间,实现只切感兴趣区域,尤其是条带状的河流流域这种情况较常见。当浏览到感兴趣区域外围由于没有切片就出现404错误,根本原因是该区域没有切片。

解决思路:

软件版本:arcgis10.6.1

按照图示的思路:

1、停止对应的地图服务,如图所示,点击对应地图服务的停止按钮。

2、将空白图片放置到站点该地图服务的缓存切片目录的_alllayers下,如图:

图片:

链接:https://pan.baidu.com/s/1IGtg2lcGhRz8g929JuZu4A 
提取码:c4tu 
 

该图片通过这种方式获取:Common caching questions—ArcGIS Server | Documentation for ArcGIS Enterprise

3、点击该地图服务的启动按钮。

4、给对应的切片服务在admin后台加上Tilemap参数,这样加载时只会加载缓存数据。

加载该服务不会有404错误

补充:

如果使用arcgis js api加载时没有切片的区域在大比例下存在重采样的情况,如图:

可以按照链接的方法在切片服务中加上禁用重采样参数。

How To: Enable Resampling for a Map Service in the ArcGIS Server Administrator Directory

ArcGIS Server 缓存服务重采样_支持对缓存的地图和图像服务启用重采样-CSDN博客

10.8以前,自带重采样这种效果

10.8及以后,需要在server manager中设置resampleing