ARTICLE DETAIL

建站实战干货

来自一线的建站与推广经验沉淀,每一条都经过真实交付验证。

关于Ubuntu下docker-mysql:ERROR 2002报错

2026/9/24 2:31:13 拓冰建站 浏览量
关于Ubuntu下docker-mysql:ERROR 2002报错

 报错场景:

mysql容器创建好后登录mysql时即使密码正确也是报出下方提示:

原因是在创建mysql容器在创建时本地目录缺失,

先去自建一个目录,例如:

/opt/my_sql

正确完整目录如下:

docker run  --name=mysql -p 3306:3306 -v /opt/my_sql:/var/lib/mysql -e MYSQL_ROOT_PASSWORD=123456 -d [镜像ID]

        --name  [自定义容器名称]     //配置容器名称

        -p 系统映射端口:容器mysqld端口       //映射系统端口

        -v 系统目录:docker目录     //映射系统目录

        -e //配置数据库密码

重新进入容器

 docker exec -it mysql mysql -u root -p

*docker exec

        -i 交互模式

        -t 进入容器CLI模式

        [容器名称]

        [容器执行命令]

重新登录数据库,报错消失。