ARTICLE DETAIL

建站实战干货

来自一线的建站与推广经验沉淀,每一条都经过真实交付验证。

磐维dbops运维管理工具重启后进程崩溃无法启动问题

2026/10/7 14:52:59 拓冰建站 浏览量
磐维dbops运维管理工具重启后进程崩溃无法启动问题 中国移动磐维数据库PanWeiDB简称“磐维数据库”。是中国移动信息技术中心首个基于中国本土开源数据库打造的面向ICT基础设施的自研数据库产品。其产品内核能力基于华为 OpenGauss 开源软件并进一步提升了系统稳定性。本文介绍磐维dbops运维管理工具重启后进程崩溃无法启动问题的解决办法希望对大家有所帮助。一、问题背景某业务在使用磐维dbops运维管理工具时在导入license之后需要重启dbops加载license但是在重启之后发现dbops启动半分钟左右会出现崩溃现在多次重启均出现崩溃二.问题分析登录dbops所在机器后台查看dbops状态过一会我们查看dbops端口9494的程序监听状态发现已经没有了dbops的监听我们发现我们刚重启后dbops的状态是正常的过了一阵之后dbops状态就不正常了这也是为什么我们重启完dbops之后还能打开网页但是过一阵之后就打不开网页的原因我们查看一下dbops的运行日志日志中的报错信息提示是Error starting ApplicationContext. To display the conditions report re-run your application with debug enabled. Application run failed java.lang.IllegalStateException: Failed to execute ApplicationRunner经过一系列排查最后定位到是dbops的配置库当中public.ops_host这张表中的name列数据出现了关键字冲突需要把这里的平台管理改成管理平台update public.ops_host set name 管理平台 where host_id 之后再次启动dbops工具发现就正常了dbops启动成功三.结论造成dbops启动失败的根本原因是dbops的配置库当中public.ops_host这张表中的name列数据出现了关键字冲突若大家遇到此类问题可以直接定位到配置库中查看public.ops_host表信息来确认问题根因。